I have a Dell Studio 17 for my office computer. It’s a nice machine, but Vista fails horribly on it. The ATI driver for it causes a BSoD on average, once a day. I’ve finally had enough, so I’m switching over to Ubuntu 8.10, Intrepid Ibex.

I’m writing this post as I install and configure Ubuntu. This will make it easier for me to keep track of what I did in case I need to undo something later or if anybody reading this wants to make the switchover as well.

Installing

Ubuntu truly has an incredible installer. There isn’t much to talk about since it was so easy.

I even installed Ubuntu while keeping Windows intact. This used to be extremely difficult. That is not the case anymore. I simply used the “Guided – resize” option. This option allows you to easily resize the Windows partition to create a new partition from the freed space where Ubuntu will be installed. I easily selected to give Windows and Ubuntu each a 100GB partition. The resizing took about half an hour. My only complaint is that the progress bar went from 0% to done with no intervals indicating how much time remained.

Overall, the installation took about 45 minutes with most of that time spent resizing the partition. Not only did the installer resize the partition and easily install Ubuntu, but it also imported many settings and options from my user on Windows. If the installation is this easy now, I can only imagine how amazing the installer is going to be a few versions from now.

I didn’t test everything, but the machine seemed to be completely functional at this point. All graphics were fluid, I was easily able to connect to my WPA2 access point, and sound worked. Now it’s time get everything set up the way I want.

Configuration

Drivers

Two proprietary drivers were available after the system booted up: “Broadcom STA wireless driver” and “ATI/AMD proprietary FGLRX graphics driver.” I activated the Broadcom proprietary driver which was quickly installed. I then tried to activate the AMD proprietary driver, but it failed without an error or message. I decided that I might need to update the system first.

I ran System > Administration > Update Manager and updated all the installed packages. I then rebooted the system. After this, I was able to activate the AMD proprietary driver without any issues.

Firefox

I use a highly-customized version of Firefox. Unfortunately, these modifications didn’t transfer over so well from Windows to Ubuntu. When I loaded Firefox, I found that I didn’t have half of the menu, the address bar was gone, and the View menu was gone so that I couldn’t fix it. I closed Firefox and decided that I would come back and figure it out later. For some unknown reason, I started Firefox again, and amazingly, it had reset itself back to default. Odd things like this confuse me and I typically don’t like them, but this odd behavior had a really good result in that it gave me a functional browser.

In previous versions of Ubuntu that I’ve played with, adding Flash to Firefox was amazingly easy: visit a site that uses Flash, click to install Flash, and you’re done. For some reason, this is different in Ibex. When I visited Youtube, I got the following message:

Hello, you either have JavaScript turned off or an old version of Adobe’s Flash Player. Get the latest Flash player.

When I visited the link, all the options offered were for 32-bit systems yet my install was 64-bit. Needless to say, none of the options worked.

I ended up finding the following instructions to install Flash 10 easily on Ubuntu 64-bit.

$ wget http://queleimporta.com/downloads/flash10_en.sh
$ sudo bash ./flash10_en.sh

I then noticed that the backspace key didn’t take me to the previous page. Fortunately I found Fix Firefox Backspace to Take You to the Previous Page, which fixed the problem immediately.

So far, everything else seems to be working as expected, including the forward/back keys on my mouseĀ  going forward/back in pages and middle-clicking opening up links in a new tab.

Packages

I installed the following packages:

audacious, compizconfig-settings-manager, emerald, mplayer, rar, subversion, thunderbird, unrar, vim, vlc, wine

Misc Changes

After getting those packages loaded, I loaded Sessions (System > Preferences > Sessions) and added a new program. I gave it a name of “Emerald” and put in a command of “emerald — replace”. This loads up Emerald each time Ubuntu boots. I then loaded the Royale Vista II Dark by dobee theme. I also configured Compiz using System > Preferences > CompizConfig Settings Manager.

I loaded up some videos and audio files and selected to install the required codecs. Due to having Compiz, the video flickered badly in MPlayer, so I switched the video driver to x11. I still have some video issues (such as the video not resizing when I change the window size), but I hope to have those issues taken care of soon.

I wanted to be able to use the Win key for creating hotkeys, and that requires a change in Ubuntu. Load the Keyboard Preferences via System > Preferences > Keyboard. Click the Layouts tabs and the “Other Options…” button. Expand “Alt/Win key behavior” and change it to “Super is mapped to the Win-key”. Now you can use the Win key for creating hotkeys. For example, I bound win+e to open the Home folder, win+c to run calculator, win+r to load the run dialog, etc.

I changed the workspaces from 2 to 4 in order to make it an actual cube. Just right-click the workspace panel in the bottom-right, select Preferences, change the Columns to 4, and click Close.

Conclusion

So far, everything is working very well. I haven’t hit any major problems except for the video codec issue, which isn’t a major issue currently since this is a work machine and not a general use machine. I’ll need to find a solution however.

I’m going to bring my laptop into the office tomorrow and see how well it does in actual use. Stay tuned for the “rest of the story.”